読者です 読者をやめる 読者になる 読者になる

メモ:S4のクラスをつくるときはCollateが必要

DBIを使ったパッケージをつくろうとしていて、なんか

in method for 'dbConnect' with signature '"SPARQLDriver"': no definition for class "SPARQLDriver"

みたいなエラーが出る。

なんでかなと思って調べてたら、

Collate controls the order in which R files are sourced. This only matters if your code has side-effects; most commonly because you’re using S4.
(Package basics · R packages)

とか書いてあった。奥が深い。たぶん↓こんな感じ。

SPARQLDBI/DESCRIPTION at 8475b2c5ad0039c6f3cb9bff864cd6a31346671d · yutannihilation/SPARQLDBI · GitHub