読者です 読者をやめる 読者になる 読者になる

FreeBSD 10.0-RC3 で phantomJSをビルド(途中)

FreeBSD

まだpkgに入ってないみたいなので(FreeBSD 9ならふつうにpkg installで済む)、
ビルドしてみることに。
※まだ成功してません

公式ページのMac OS Xの手順をそのままやるだけだとエラーが出る。

Build | PhantomJS

pkg install git

git clone git://github.com/ariya/phantomjs.git
cd phantomjs
git checkout 1.9
./build.sh

とりあえずこんな感じで対処。まだエラー出るけど

# g++がない、というエラーが出るのでシンボリックリンクをはる
ln -s g++46 /usr/local/bin/g++

# $OSTYPEが"FreeBSD"になっていて、"freebsd"と一致しないのでenvで一致するようにする
env OSTYPE=freebsd bash ./build.sh

追記

けっきょくうまくいかないのであきらめて、FreeBSD 9.2でpkg install phantomjsしました。くやしい。。